mardi 8 mars 2016

Oracle VM VirtualBox - Problème du Gestionnaire de médias

Juste pour prendre note sur un "gros problème" à mon sens, du gestionnaire de médias d'Oracle Virtual Machine. Vous avez un problème avec le clonage d'une machine, sous Oracle VM VirtualBox, c'est normal ! Il y a un truc vraiment idiot :
  • vous clonez un machine
  • vous la déplacez
  • vous renommez la machine
Cette nouvelle machine est encore attachée au anciens disques durs à l'ancien emplacement ! Alors vous supprimez les références aux anciens disques, pour y ajouter les références aux nouveaux disques durs et là ... c'est le drame  :

Echec de l'ouverture du fichier de disque dur xxxWindows-xxx-disk1.vhd.
Cannot register the hard disk 'xxWindows-xxx-disk1.vhd' {fdeaf81c-9cea-4e8c-a572-507a4ce10c62} because a hard disk 'xxWindows-xxx-disk1.vhd' with UUID {fdeaf81c-9cea-4e8c-a572-507a4ce10c62} already exists.

Code d'erreur : E_INVALIDARG (0x80070057)
Composant : VirtualBox
Interface : IVirtualBox {fafa4e17-1ee2-4905-a10e-fe7c18bf5554}
Code retourné : VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)

Bla bla bla bla ... tout ceci n'est que foutaises, il vous faut Gérer les médias, Menu "Fichier" cliquez sur : "Gestionnaire de médias..." :

Oracle VM Virtualbox - Gestionnaire de médias

Dans la liste des médias gérés par Oracle VM VirtualBox, vous verrez des icônes triangle jaune indiquant que OVM ne trouve plus ces médias, c'est icônes ne sont pas présentes ici car je l'ai déjà fait ;) :

Oracle VM VirtualBox - Gestion des médias

Supprimez les médias précédés de cette petite icône jaune et vous pourrez attacher vos nouveaux disques clonés à votre nouvelle machine.

Le monde n'est-il pas formidable ?

4 commentaires:

  1. J' ai essayé mais ça n'a pas marcher le message persiste

    RépondreSupprimer
    Réponses
    1. Vous avez du rater quelque chose, il est possible que ce ne soit pas clair mais essayez encore car c'est la solution

      Supprimer
  2. Bonjour, pour ma part la liste est vide d'emblée

    RépondreSupprimer
  3. Bonjour, il s'agit très certainement d'une méprise de votre part. Votre machine virtuelle possède au moins un disque système, sinon elle est vide. Je suppose que vous avez trouvé une solution.

    RépondreSupprimer